Calls are displayed in the history with a delay for RU region
Incident Report for Voximplant
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 11:00 UTC
Investigating
We are currently investigating this issue.
Posted Mar 01, 2024 - 06:30 UTC
This incident affected: Control panel.