Some incoming and outgoing calls to Russian numbers (RU region) may not go through.

Incident Report for Voximplant

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 09:50 UTC

Investigating

We are currently investigating this issue.
Posted Mar 03, 2026 - 09:32 UTC
This incident affected: Voximplant Kit RU (PSTN inbound, PSTN outbound), Voximplant Kit RU2 (PSTN inbound, PSTN outbound), and Voximplant Platform RU (PSTN connectivity - outbound, PSTN connectivity - inbound).