Difficulties with some outbound calls from Russian landline numbers

Incident Report for Voximplant

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 07:50 UTC

Investigating

We are currently investigating this issue.
Posted Feb 25, 2026 - 15:40 UTC
This incident affected: Voximplant Platform RU (PSTN connectivity - outbound), Voximplant Kit RU (PSTN outbound), and Voximplant Kit RU2 (PSTN outbound).