Some incoming calls to Moscow Russia numbers may not go through

Incident Report for Voximplant

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 15:00 UTC

Identified

The problem has been resolved for most calls. We are still working on the remaining difficulties.
Posted Aug 18, 2025 - 08:24 UTC

Investigating

We are currently investigating this issue.
Posted Aug 18, 2025 - 05:21 UTC
This incident affected: PSTN connectivity - inbound (PSTN inbound - RU).